Cisco Cisco ios Cisco tips and tricks GRE Tunnel Networking networking tips and tricks router routing tips and tricks Tunnel in cisco,
How to setup a GRE tunnel on a Cisco Router ?
Posted by Anbu
Published on Monday, February 18, 2013
Problem:
How to setup a GRE tunnel on a Cisco Router ?
Solution:
So, let’s warm up the new year with an easy tutorial on how to setup a GRE tunnel on a Cisco router.
Consider this scenario:
Router1 = 172.16.1.1
Router2 = 192.168.0.1
The routing between these routers are fixed so that they can reach each other, like on the internet.
Router2 will have the network 10.0.10.0/24 routed to it via a GRE tunnel.
The address on the tunnel interfaces will be 10.0.0.1 and 10.0.0.2 for Router1 and Router2 respectively.
Router1 configuration:
Router1(config)#interface Tunnel 0
Router1(config-if)#tunnel source 172.16.1.1
Router1(config-if)#tunnel destination 192.168.0.1
Router1(config-if)#tunnel mode gre ip
Router1(config-if)#ip address 10.0.0.1 255.255.255.252
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#ip route 10.0.10.0 255.255.255.0 10.0.0.2
Router1(config)#interface Tunnel 0
Router1(config-if)#tunnel source 192.168.0.1
Router1(config-if)#tunnel destination 172.16.1.1
Router1(config-if)#tunnel mode gre ip
Router1(config-if)#ip address 10.0.0.2 255.255.255.252
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#ip route 10.0.10.0 255.255.255.0 Null 0
You can now setup addresses within 10.0.10.0/24 on any interface you want and use them like as they were routed to your router directly.
The traceroute from Router2 to Router1 should look something like this:
Router2#traceroute 10.0.0.1
Type escape sequence to abort.
Tracing the route to 10.0.0.1
1 10.0.0.1 8 msec 8 msec 8 msec
Voila, we got routing over GRE!
How to setup a GRE tunnel on a Cisco Router ?
Solution:
So, let’s warm up the new year with an easy tutorial on how to setup a GRE tunnel on a Cisco router.
Consider this scenario:
Router1 = 172.16.1.1
Router2 = 192.168.0.1
The routing between these routers are fixed so that they can reach each other, like on the internet.
Router2 will have the network 10.0.10.0/24 routed to it via a GRE tunnel.
The address on the tunnel interfaces will be 10.0.0.1 and 10.0.0.2 for Router1 and Router2 respectively.
Router1 configuration:
Router1(config)#interface Tunnel 0
Router1(config-if)#tunnel source 172.16.1.1
Router1(config-if)#tunnel destination 192.168.0.1
Router1(config-if)#tunnel mode gre ip
Router1(config-if)#ip address 10.0.0.1 255.255.255.252
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#ip route 10.0.10.0 255.255.255.0 10.0.0.2
Router1(config)#interface Tunnel 0
Router1(config-if)#tunnel source 192.168.0.1
Router1(config-if)#tunnel destination 172.16.1.1
Router1(config-if)#tunnel mode gre ip
Router1(config-if)#ip address 10.0.0.2 255.255.255.252
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#ip route 10.0.10.0 255.255.255.0 Null 0
You can now setup addresses within 10.0.10.0/24 on any interface you want and use them like as they were routed to your router directly.
The traceroute from Router2 to Router1 should look something like this:
Router2#traceroute 10.0.0.1
Type escape sequence to abort.
Tracing the route to 10.0.0.1
1 10.0.0.1 8 msec 8 msec 8 msec
Voila, we got routing over GRE!
0 comments
Readers Comments